Support

Contact

Send us an email to share feedback or get help with Astropad.

Guides

Browse our starter guides for program specific help

Community

The place to discuss anything and everything about Astropad.

FAQ

Frequently asked questions about hardware, software, and account information.

Manuals

A step-by-step guide for getting started: Astropad Studio / Astropad Standard

Downloads

Download the free Mac companion apps: Astropad Standard / Astropad Studio.

Common Questions

VIEW ALL FAQs

Recommended System Requirements

We recommend a 2013 or newer MacBook Pro, iMac or Mac Pro for the best experience.

Minimum System Requirements

Astropad Standard: macOS 10.9 or later, and iOS 8 or later

Astropad Studio: macOS 10.10 or later, and iOS 9 or later

Astropad Mini : macOS 10.9 or later, and iOS 8.2 or later

Does Astropad require a Mac?

Yes, a Mac is required. Astropad mirrors your Mac screen and connects via USB or Wifi.

What programs work with Astropad?

We’re continuously working to improve software compatibility. Our ongoing list is available – here.